Docs GODI Archive
Projects Blog Knowledge

Look up function:

(e.g. "List.find" or "keysym")
More options
"findlib-browser" is a CGI script/program that allows the user to
browse through packages which have been installed by "findlib".


REQUIREMENTS:

This script only works with Ocaml 3.07. Earlier releases are not
supported.

Of course, a "findlib" installation is required. You need release
1.0.1 or newer.

Furthermore, ocamlnet is required.

You need a WWW server. Every WWW server that supports the CGI interface
should work.


BUILD:

- Normally you can invoke the script browser.cgi directly (check
  the ocaml path, however).

  Test the script by invoking ./browser.cgi; enter nothing as
  query string. The result must be an HTML page.

  The script is mainly intended for development.

- It is possible to compile the script. Just do "make".

  -->		  THIS IS THE RECOMMENDED METHOD.
 

INSTALL:

The compiled script can be installed by "make install".


CONFIGURING THE WWW SERVER:

The WWW server must be configured such that it is allowed to start
cgi programs. See the documentation of your WWW server.


CHANGES:
- 0.2.2: Bugfix release, producing the correct header.


AUTHOR:

This application has been written by Gerd Stolpmann, 
gerd@gerd-stolpmann.de

You can download it from 
http://www.ocaml-programming.de/packages/.

This application has an entry in the O'Caml link database,
http://www.npc.de/ocaml/linkdb/



This web site is published by Informatikb√ľro Gerd Stolpmann
Powered by Caml